1

Topic: PunBB обновления от Visman

На днях на официальном форуме разработчик Visman внёс существенные изменения в форумный движок PunBB для совместной работы с php 7.4. Хотя пока официально от Informer'a об этом объявлено не было, тем не менее движок готов для установки или же обновления.

Желательно перевести форум в режим профилактики на время обновления, это можно найти в настройках.
У движка та же версия 1.4.4, поэтому просто скопируйте новые файлы поверх старых.
Не забудьте сделать бэкап файлов и базы данных.

Узнать о всех обновлениях на официальном форуме.

Посмотреть и скачать файлы на гитхабе.

2

2

Re: PunBB обновления от Visman

Там вроде всего несколько файлов изменено, можно только их поменять.

---------------------------------

На 7.4 форум будет летать просто фантастически быстро даже если расширений всяких понавешать.

3

Re: PunBB обновления от Visman

обновился. Что не так ?
This t doesn't have MySQL support built in. MySQL support is required if you want to use a MySQL database to run this forum. Consult the PHP documentation for further assistance.

---------------------------------

php -v
PHP 7.3.13RC1 (cli) (built: Dec  3 2019 15:47:46) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.3.13RC1, Copyright (c) 1998-2018 Zend Technologies


mysql --version
mysql  Ver 14.14 Distrib 5.5.62, for Linux (x86_64) using readline 5.1

4

Re: PunBB обновления от Visman

@oleksandr-komark?n, вы бы вначале вместо ссылки на страницу вконтакте поменяли ссылку на ваш форум  PunBB_INFO_ICQ/no

5 (edited by kirpich 2019.12.19 04:09)

Re: PunBB обновления от Visman

oleksandr-komark?n wrote:

This t doesn't have MySQL support built in. MySQL support is required if you want to use a MySQL database to run this forum. Consult the PHP documentation for further assistance.

Нет поддержки mysql в связке с этой версией php ... она как бы официально отключена полностью с версии php6
https://habr.com/ru/post/124245/

---------------------------------

Связка
PHP: 7.4.0RC4
MySQL Improved 5.5.64
Проверил- работает.


---------------------------------

Что-то после этих обновлялок память жрать стало... надо разбираться

6

Re: PunBB обновления от Visman

kirpich wrote:

память жрать стало... надо разбираться

PunBB_INFO_ICQ/bigsmile Нет ли связи?

kirpich wrote:

На 7.4 форум будет летать просто фантастически

7

Re: PunBB обновления от Visman

kisa wrote:

Нет ли связи?

Есть...  PunBB_INFO_ICQ/crasy Но летало хорошо! Правда не очень долго  PunBB_INFO_ICQ/rofl

8 (edited by DronSF 2020.02.21 08:09)

Re: PunBB обновления от Visman

В начале февраля еще обновления появились

21. Fixes for SQLite(3)
22. Change set_names() for mysqli
23. Fix URL schemes for get host + ipv6
24. Fix decreasing transaction counter
25. Fix error() in mysqli_innodb
26. Fixes for MySQL 8

Об этом на оф. форуме
скачать на Гитхабе

---------------------------------

Но с любым из обновлений появляется ошибка, если включено расширение  First post • Версия 0.4.2 • Разработчик: KANekT
расширение полезное но похоже давно заброшенное, не хотелось бы его отключать. И не зависимо включено/выключено ли в теме "Закрепить первое сообщение в теме". Где можно подправить, чтобы не было ошибок?

При входе в форум (сверху):

Spoiler

Deprecated: Non-static method FirstPost_Hook_Dispatcher::topic_init() should not be called statically in E:\webdesign\OSPanel535u\domains\web1\viewforum.php(15) : eval()'d code on line 15
Deprecated: Non-static method FirstPost_Hook_Dispatcher::select_first_post() should not be called statically in E:\webdesign\OSPanel535u\domains\web1\viewforum.php(150) : eval()'d code on line 45

При входе в тему (сверху):

Spoiler

Deprecated: Non-static method FirstPost_Hook_Dispatcher::topic_init() should not be called statically in E:\webdesign\OSPanel535u\domains\web1\viewtopic.php(15) : eval()'d code on line 29
Deprecated: Non-static method FirstPost_Hook_Dispatcher::select_first_post() should not be called statically in E:\webdesign\OSPanel535u\domains\web1\viewtopic.php(144) : eval()'d code on line 37

над первым сообщением:

Spoiler

Deprecated: Non-static method FirstPost_Hook_Dispatcher::vt_qr_get_posts() should not be called statically in E:\webdesign\OSPanel535u\domains\web1\viewtopic.php(323) : eval()'d code on line 37
Deprecated: Non-static method FirstPost_Hook_Dispatcher::vt_row_pre_post_ident_merge() should not be called statically in E:\webdesign\OSPanel535u\domains\web1\viewtopic.php(355) : eval()'d code on line 43

Между сообщениями:

Spoiler

Deprecated: Non-static method FirstPost_Hook_Dispatcher::vt_row_pre_post_ident_merge() should not be called statically in E:\webdesign\OSPanel535u\domains\web1\viewtopic.php(355) : eval()'d code on line 43

При написании сообщения(ответа):

Spoiler

Deprecated: Non-static method FirstPost_Hook_Dispatcher::post_init() should not be called statically in E:\webdesign\OSPanel535u\domains\web1\post.php(16) : eval()'d code on line 80
Deprecated: Non-static method FirstPost_Hook_Dispatcher::po_pre_optional_fieldset() should not be called statically in E:\webdesign\OSPanel535u\domains\web1\post.php(512) : eval()'d code on line 9